forums.PPSSPP.org
Unable to run any game - Printable Version

+- forums.PPSSPP.org (https://forums.ppsspp.org)
+-- Forum: PPSSPP - Playstation Portable Simulator Suitable for Playing Portably (/forumdisplay.php?fid=1)
+--- Forum: General Discussion and Announcements (/forumdisplay.php?fid=2)
+--- Thread: Unable to run any game (/showthread.php?tid=6079)



Unable to run any game - Broth3r - 08-30-2013 09:37 PM

Evening, ladies and gentlemen.

Just installed the emulator and I'm not being able to run any commercial games whatsoever. Can't find a report similar to mine either. The emu menus load up fine, but when I try to run any game, I get the following:

[Image: T0hnwNJ.png]

Tried a bunch of compatible games, all with the same result - with the notable exception of AsC Bloodlines, which shows no white box. Haven't tried any homebrew yet. I'm guessing it's a rendering issue, given the size and placement of the box. Probably related to my GPU, which is an awful onboard Intel (a 965), but again the menus do run smooth.

Running the 64bit version on Windows 7 Ultimate.


RE: Unable to run any game - TheDax - 08-30-2013 09:57 PM

Apparently your GPU, if I'm seeing this right(no such thing as an Intel 965 GPU, that motherboard had a GMA X3000 or GMA X3100 iirc), only supports OpenGL 1.5, so you won't be able to run PPSSPP correctly. Sorry.

However, if I'm wrong, feel free to correct me. If you want to find out definitively what specs you have, I reccomend Speccy(just say no when it asks you to install that crap like Chrome/make whatever your homepage).


RE: Unable to run any game - Broth3r - 08-30-2013 10:08 PM

Ugh. Worse case scenario confirmed. Was hoping being able to run the emu at all would put me in the clear, but this toaster is that bad. Not even able to run OGL 2.0...

Well, thanks anyway.


RE: Unable to run any game - TheDax - 08-30-2013 10:17 PM

I'd still check out Speccy or some other system information application before you totally throw in the towel, but it doesn't look good if I looked that up right..


RE: Unable to run any game - solarmystic - 08-31-2013 12:49 AM

@Broth3r

Before you give up, update your Chipset Drivers/Integrated Graphics Card Drivers from Intel:-

https://downloadcenter.intel.com/default.aspx

According to my guide, if it truly is an Intel 965 chipset (desktop), it should be able to support OpenGL 2.0 at the minimum.

Quote:Fourth generation:-
(Only OpenGL 2.0 support on Windows and OpenGL 2.1 support on Linux. Yep, Intel did it again.)

GMA 3000 (946GZ, Q963, Q965)
GMA X3000 (G965)
GMA X3500 (G35)
GMA X3100 (GL960, GLE960, GM965, GME965)

And since running the application did not net you the infamous "PPSSPP has stopped working" error, there is some hope left for your machine. A complete fail would be getting that error followed by an app crash right after launching the emulator, like many other Intel chipsets would get if they're totally incapable of OGL 2.0.


RE: Unable to run any game - TheDax - 08-31-2013 12:47 PM

Oh, really? My preliminary search showed those only went up to 1.5..guess I need to work on my Googlefu.


RE: Unable to run any game - Broth3r - 09-01-2013 09:23 AM

It's a laptop, though. Speccy fails to see beyond beyond the model family - Mobile Intel 965 Express Chipset Family - although, awkwardly, it shows two boards with different IDs.


RE: Unable to run any game - vsub_ - 09-01-2013 10:44 AM

Wouldn't be nice to show some kind of message(on the screen or msgbox)while starting pppsspp if the GPU don't meet the minimum requirements(OGL 2.0)