forums.PPSSPP.org
Cars Race-o-Rama ULES01333 - Printable Version

+- forums.PPSSPP.org (https://forums.ppsspp.org)
+-- Forum: PPSSPP - Playstation Portable Simulator Suitable for Playing Portably (/forumdisplay.php?fid=1)
+--- Forum: Commercial Games - Compatibility and Results (/forumdisplay.php?fid=5)
+---- Forum: In-game (/forumdisplay.php?fid=15)
+---- Thread: Cars Race-o-Rama ULES01333 (/showthread.php?tid=5642)



Cars Race-o-Rama ULES01333 - Tabman - 08-19-2013 06:09 PM

Title: Cars Race-o-Rama
Disc ID: ULES01333
Genre: Racing
Region: EUR
Format: ISO
Version: PPSSPP 0.9.1-186 x64 (x86 not tested)
OS: Windows 7 64 bit
Compatibility: Ingame
Notes: Movies (I assume) show only blackscreen, GFX are very strange (picture 3).
[attachment=7447][attachment=7448][attachment=7449]

NEW Ingame Log file x64:[attachment=7450]
OLD Log file:[attachment=7145]

Edit:updated post for 0.9.1-186


RE: Cars Race-o-Rama ULES01333 - Tabman - 08-26-2013 07:22 PM

Please move to the In-game forum if you find the time.
Thanks and hugs Heart


RE: Cars Race-o-Rama ULES01333 - vnctdj - 08-26-2013 07:40 PM

(08-26-2013 07:22 PM)Tabman Wrote:  Please move to the In-game forum if you find the time.
Thanks and hugs Heart

Moved Wink


RE: Cars Race-o-Rama ULES01333 - GuilhermeGS2 - 11-22-2013 04:10 PM

any news?

Updated the compatibility list.


RE: Cars Race-o-Rama ULES01333 - sabrespectre - 09-21-2014 05:28 AM

v0.9.9.1-492-gdda3ca3 Win7 64
Still no luck with this one..... great problems in game graphics.


RE: Cars Race-o-Rama ULES01333 - livisor - 03-18-2017 11:13 PM

Can someone test this game? i can get ingame and do races but frambuffer places a white screen on top of the gamescreen(opengl is better than d3d11)


RE: Cars Race-o-Rama ULES01333 - melancholy76 - 06-15-2018 12:56 PM

Hi guys!

It would be great if we could hear from someone replying to this thread who personally dumped the game ISO onto their computer and see if the problem's only limited to the ISO or just the way how the emulator handles things internally.

One very interesting thing I noted while emulating this game on Windows 7(64-bit), PPSSPP v1.1.1 (D3D9 I think I used) with AMD Radeon graphics card is that 90% of the screen was black with mostly HUD showing, the rest 10% showing the game graphics, the FPS dropped considerably and, depending on night or day races, the night race's skybox texture was pink for whatever reason.
Windows 10 PPSSPP v1.5.4, D3D11, NVidia GeForce 940MX, no such black box, FPS drops again with 70-73% decrease, however with the exception of the HUD, many of the textures for the ground, cars, scenery were fully black with few exceptions.

Screenshots of my test run

PPSSPP-RoRDEBUGCP1.JPG shows interesting stuff, example it shows 13 Pitch values (and sometimes Pitch 16??), whereas I'm not pressing every button and in the main menu it only shows Pitch 0 and Pitch 1 values for me on Windows 10 PPSSPP v1.5.4. Plus the slowest and most active 'syscall' are the same


Message from Debug Console
05:42:397 main_thread E[SCEDISP]: HLE\sceDisplay.cpp:862 80000104=sceDisplaySetFrameBuf(04000000, 480, 1, 1): invalid stride

update:

new screesnshot with openGL, no FPS drop at all but black textures

Vulkan renderer crashes the entire Emulator after the loading screen