Zettai Zetsumei Toshi 3 (絶体絶命都市3) - Printable Version

+- (
+-- Forum: PPSSPP - Playstation Portable Simulator Suitable for Playing Portably (/forumdisplay.php?fid=1)
+--- Forum: Commercial Games - Compatibility and Results (/forumdisplay.php?fid=5)
+---- Forum: In-game (/forumdisplay.php?fid=15)
+---- Thread: Zettai Zetsumei Toshi 3 (絶体絶命都市3) (/showthread.php?tid=2956)

Pages: 1 2

Zettai Zetsumei Toshi 3 -K owareyuku Machi to Kanojo no Uta - jamespeng11 - 04-16-2013 04:43 AM

Game Title : Zettai Zetsumei Toshi 3 -K owareyuku Machi to Kanojo no Uta
Game version(US/JP/EU/WWE): JP
File format(ISO/CSO/EBOOT): ISO
Compatibility level(nothing/intro/menus/ingame/playable): After choosing New Game, it go to character choice screen and stuck. (as the image show)

[Image: Screenshot_2013_04_16_13_31_47.png]

Zettai Zetsumei Toshi 3 (絶体絶命都市3) - Grezen - 04-24-2013 08:28 AM

[Image: thumb.jpg]

This game still not working at ppsspp the 0.7.6

is got show a loading screen after just keep black screen..
but the ppsspp 0.7.5 old version bit got show the menu after select the player stop on there...

RE: Zettai Zetsumei Toshi 3 (絶体絶命都市3) - BazookaHarwell - 04-27-2013 11:39 AM

Title: Zettai Zetsumei Toshi 3: Kowareyuku Machi to Kanojo no Uta
Genre: Action Platformer
Region: NTSC-J
Format: ISO
Version: v0.7.6
OS: Android
Compatibility: Menus
Notes: When the game is started for the first time, the game will ask if you wish to create a new save file. After agreeing, the game will then hang on a black screen. When the game is restarted, the user is greeted with a menu which says that the save file will be loaded (see attachment). Like before, the game will hang on a black screen once the user progresses past this menu. Please contact me if you require additional information.

Edit: I was unable to reproduce the original poster's experience. 0.7.5 seems to offer worse compatibility for the game, as not only does it still hang after a menu, but it cannot display any Japanese characters either in-game or for the title of the game. This was using just vanilla 0.7.5 from Git (the 0.7.5 download link on the main page is broken, as it shares the same redirect as the 0.7.6 does), and he seems to be using a different revision. I'll check it out... Scratch that, it does load on 0.7.5, it just takes a long while. I think what's happening is that it's playing through some video that's not showing up... That definitely seems to be the case, as the menu comes up immediately with media engine turned off.

Edit2: I tried looking for the revision in the screenshot posted by the OP, but the earliest I found was 0.7.5-20. Even though the first menu is not rendered properly (which is fixed by 0.7.6), the game does not hang after the first menu. Button inputs seem to not be working on the character select menu or something, I'll play with it a bit more and find the revision in which the game returns to hanging after the first menu. The character screen itself, however, is not frozen.

Edit3: The game starts hanging on either revision 0.7.5-113, 0.7.5-114, 0.7.5-115, or 0.7.5-116 (the game works on the cutscene in revision 112 (v0.7.5-112-gfa204c6), but everything is dead in 116 (v0.7.5-116-ge6beb97). I could not find revisions 113, 114, or 115, so that's as far as I can narrow it). Models are going through idle animations on the character select screen for revisions that can reach that screen, and the game is definitely working on things, but it just seems like the game does not respond to button inputs any more. Please note that I do have to press circle to get through loading my saved data and to start the game, and that does work. Also, the sound does not work. The second attachment below was taken on revision v0.7.5-112-gfa204c6.

Edit4: On revision v0.7.6-164-gc1a2ee5, Zettai Zetsumei Toshi 3 grinds to about .2 frames a second about 10 frames in, effectively making the compatibility nothing. I'll leave it running for a bit. See third attachment.

Edit5: Okay, revision v0.7.6-164-gc1a2ee5 loads and works through the cutscene in the beginning that 0.7.6 dies at. It seems to do some other work, possibly for the menu before the character select menu (with the options like new game, load game, etc.), and then it dies and hangs on a black screen without having brought anything up. Also, it did grind to a halt numerous times before reaching the "load save data" menu, and I don't know what is up with that. It doesn't actually take that long to get past, but it's a curious little thing that doesn't happen in earlier revisions.

RE: Zettai Zetsumei Toshi 3 (絶体絶命都市3) - BazookaHarwell - 04-28-2013 10:46 AM

Posted two attachments of revision 0.7.6-221's logs for anyone interested. These logs occur when the in-game movie either finishes on its own, or is skipped. Then the game dies, as said before.

RE: Zettai Zetsumei Toshi 3 (絶体絶命都市3) - BazookaHarwell - 04-29-2013 01:57 PM

Update: On 0.7.6-266 for Windows 32-bit (have not tried this revision on Android), the game now reaches the character select menu again, and audio is now working (you can hear a chime when you select "new game"). Button inputs still do not work on the character select menu for whatever reason.

Unlike revision 0.7.5-112, PPSSPP crashes after about five seconds on the character select screen. However, I can't get 0.7.6-266 to crash consistently, so it is likely my craptop.

Edit: The crashes are pretty definitely on my end.

RE: Zettai Zetsumei Toshi 3 (絶体絶命都市3) - BazookaHarwell - 04-29-2013 11:49 PM

Another update: I wanted to say that this game is playable, but there's a catch. Since button input just dies, for whatever reason, on the character selection screen, you can load a save game that has completed one of the campaigns (so the save data will start you at the start of the campaign you just finished) to get around that (for example, a save at will start you out at the beginning of the campaign for the first character).

Some long subtitles spaz out just a little bit and the character model is not visible. The shadow below the invisible character model, however, is visible. However, I have found no way to start a new campaign without loading up save data that has just completed a campaign, so I don't know if this qualifies as being anywhere past menu compatibility.

RE: Zettai Zetsumei Toshi 3 (絶体絶命都市3) - sfageas - 04-30-2013 07:48 AM

Moved to Ingame

RE: Zettai Zetsumei Toshi 3 (絶体絶命都市3) - BazookaHarwell - 04-30-2013 02:30 PM

Oh, so you know, what is likely the reason that you can see the character model in the character select, but not in-game, is that there are clothing/costumes you can wear. Don't know if that tidbit of information is of any particular help, but it might be relevant. I'll keep poking at the game.

That would also explain why only the face shows up, although I don't know why it does not show up at the very beginning of the campaign (the first screenshot I have posted above has me standing outside a bus that you crawl out of at the start. If you move down a bit, rubble will start falling, which you need to run from. After you run from the falling rubble, there's a little in-game animation of the character catching his breath, and that's when the face shows up).

RE: Zettai Zetsumei Toshi 3 (絶体絶命都市3) - BazookaHarwell - 05-30-2013 09:59 PM

I wanted to post with an update. The game doesn't seem to have seen much improvement in a month, if any, but I did manage to complete the game all the way through. It can be completed on PPSSPP, although with a good amount of caveats. I would like to post additional information plus summarize the issues I have posted plus any additional issues I have found, plus shed some light onto how the game would be easier to play, even though you're basically playing as a floating head. I did this on revision 7xx (forgot to jot down the exact number, sorry), but any logs I include are from v0.7.6-935-g3d06c67.

One major issue I found is that opening the コスチューム (costume menu) causes the emulator to spectacularly crash - this also happens when picking costumes up.

Error console using JIT (I don't know exactly how to read the logs, but it looks like PPSSPP thinks I'm trying to quit the application when I open the menu/pick up a costume or something - that is not me exiting the application, and the application just turns into a black screen where I cannot do anything):

Here's the log when attempting this without JIT being enabled (in this one, I actually did close the application since it seems like it would go on forever if I did not - as you can see, PPSSPP kind of freaks out):

Even though you cannot equip any costumes, you can still equip accessories such as gloves, shoes, and hats, which will show up (and hats will also come with hair), which is odd.

Like before, there is still a slew of minor graphical issues. Also, some sounds are not emulated properly and movies do not play, which is all to be expected. However, 6 of the 9 (or 8, depending on how you want to count them...) endings end at the same point in the game, so the movie is necessary to know what ending was achieved. Of course, that'll most likely get fixed naturally.

Other than that, button inputs still completely die on the "new game" "character select" screen, which makes it impossible to go in-game, unless that save is used. I would create a save that allows someone to play as the female character, but I don't know how, as any new game+ saves I create simply drop you into the character select screen... However, they play similarly enough anyway, and they have the same stories and environments, it's just that the female character has different item pickups for compasses/costumes (which cannot be used anyway)/accessories, and the like.

RE: Zettai Zetsumei Toshi 3 (絶体絶命都市3) - BazookaHarwell - 06-15-2013 11:16 PM

There have been some improvements to the game over the last few weeks, including improved lighting, better audio, and prerendered cutscenes displaying and having audio. The prerendered cutscenes are nice because all the endings are depicted in prerendered cutscenes, but all in all it was not really worth posting about.

What I wanted to post about is that when I tested r1398, pre-rendered cutscenes no longer show up. It was probably a revision before this one, but the last one I tested, r1342, did not have this issue.

Edit: Seems to be a non-issue now on r1414.

RE: Zettai Zetsumei Toshi 3 (絶体絶命都市3) - jorgebueno - 03-22-2014 12:32 AM

I could not get it to work on x86 windows in ppsspp 0.9.7, 0.8.1 and 0.7.6 anyone can help me. thanks

RE: Zettai Zetsumei Toshi 3 (絶体絶命都市3) - HSone - 04-27-2014 06:55 AM

(03-22-2014 12:32 AM)jorgebueno Wrote:  I could not get it to work on x86 windows anyone can help me. thanks
Play Disaster Report PS2,same thing.

RE: Zettai Zetsumei Toshi 3 (絶体絶命都市3) - LunaMoo - 11-03-2014 05:46 PM

I just noticed that the game has problem on character select menu caused by some thread synchronization while otherwise looking/working fine, so I made a small cw cheat workaround for that character select screen:

_C0 freeze workaround
_L 0x20039300 0x00000000
_C0 freeze workaround [Disable]
_L 0x20039300 0x0E2F2AFA

Edit: Use this one instead.
And a small proof:

Not sure if the game has any other issues later, since I didn't really played it on ppsspp and don't plan to do it now anyway, but at least people can play without using somebody elses saves now.

RE: [Android][v0.7.5]Zettai Zetsumei Toshi 3 -K owareyuku Machi to Kanojo no Uta (JPN) - GamerzHell9137 - 01-07-2015 05:45 AM

iirc the game works fine on the latest builds. Some people are translating the game and using PPSSPP as gameplay source.

RE: Zettai Zetsumei Toshi 3 -K owareyuku Machi to Kanojo no Uta - vnctdj - 01-07-2015 11:31 AM

Moved Smile