forums.PPSSPP.org
filter/shader problem - Printable Version

+- forums.PPSSPP.org (https://forums.ppsspp.org)
+-- Forum: PPSSPP - Playstation Portable Simulator Suitable for Playing Portably (/forumdisplay.php?fid=1)
+--- Forum: Off-Topic (/forumdisplay.php?fid=16)
+--- Thread: filter/shader problem (/showthread.php?tid=24112)



filter/shader problem - ZeroX4 - 03-10-2018 04:50 PM

so in short of it

when i use Anti Aliasing shader every 3D object is sharp and just perfect
https://i.imgur.com/jkzcrEk.jpg

but when i switch to 4xHqGLSL it looks like this
https://i.imgur.com/LQ945SA.jpg

and like this on 5xBr
https://i.imgur.com/TTA2Shz.jpg

its like hq and xbr filter/shader or whatever is it proper name is trying to round all 3D objects instead of sharpening them and that is not problem with ppsspp cause i see same exact thing in other emulators

does any of you have seen this before? or is it normal? or wtf?

can anyone here post screens from any 3D game with using above shader/filter cause im pretty sure they should not work like that

if any of you have idea why it look like this for me im happy to hear it

my GFX card is nvida geforce gtx 960 if thats any difference


RE: filter/shader problem - LunaMoo - 03-10-2018 05:31 PM

(03-10-2018 04:50 PM)ZeroX4 Wrote:  (...)im pretty sure they should not work like that(...)
That's because you don't understand what such filters do;p, they sample few neighboring pixels and generate a pattern based on that, that's why if applied to full screen and not just textures:
- it only will look good in fully 2D games, which uses full psp resolution,
- will look bad in 3D graphics, zoomed in/out 2D graphics, and also why edges of non-animated moving objects will due to different edge pattern affected by background feel weird.

In short, how it looks, is exactly how it should and how it will look;p.


RE: filter/shader problem - ZeroX4 - 03-10-2018 05:44 PM

i would not have a problem if not the fact that i remember before i switched to new pc few years ago with new GFX card gtx 960 xbr hq fitler in ppsspp or epsxe looked just fine and not like on screens above


RE: filter/shader problem - LunaMoo - 03-10-2018 06:59 PM

That's because it wasn't doing what it was designed to do - "upscaling" low res graphics. You can get the old behaviour back by removing upscaling flag or setting it to false in shader ini file;].


RE: filter/shader problem - ZeroX4 - 03-11-2018 07:52 AM

when you put it this way it starts to make sense now ty