forums.PPSSPP.org
Armv6 Builds - Printable Version

+- forums.PPSSPP.org (https://forums.ppsspp.org)
+-- Forum: PPSSPP - Playstation Portable Simulator Suitable for Playing Portably (/forumdisplay.php?fid=1)
+--- Forum: Builds, releases and ports (/forumdisplay.php?fid=4)
+--- Thread: Armv6 Builds (/showthread.php?tid=142)

Pages: 1 2 3 4


Armv6 Builds - MaXiMu - 11-10-2012 08:34 AM

Now ppsspp 0.5 on googleplay you can download here





Running on :
Imap x210 1ghz
256mb SDRAM (185mb disponible)
GPU vivante GC600 graphics engine Opengl ES-CM 1.1

Commit (ce5afbc166) (0.2version.)
http://www.multiupload.nl/DI5ZFBWYDR
commit 2a56d36b12 (0.3 version)
http://www.multiupload.nl/AYMKA5CWYR
commit fd76b2bb15 with native commit 41b4cf836c (0.31 version)
http://www.multiupload.nl/5TYDHMWVRU
commit 4393dc02a6 with native 92bd22ffe5 (0.4 version)
http://www.multiupload.nl/WLPW9S1VUK


RE: First running on Armv6 device (Wip) - BillDoul - 11-10-2012 11:03 AM

I cannot download from bayfiles. Can you please upload on zippyshare or somewhere else so I can test it on my huawei sonic? Thanks.


RE: First running on Armv6 device (Wip) - MaXiMu - 11-10-2012 11:15 AM

Ok I upload multiupload link

http://www.multiupload.nl/H0XCBT0JHL


RE: First running on Armv6 device (Wip) - BillDoul - 11-10-2012 02:10 PM

I just tested it on my huawei sonic and it works. The cube.elf runs perfect. Now I must test with one of the games. I will get back to you with results.

Edit: I tested puzzle bubble and it works (a little slow but playable). Can you please convert future versions of ppsspp to armv6?


RE: First running on Armv6 device (Wip) - ssshadow - 11-11-2012 11:18 AM

It works on the ZTE Blade, clocked at 748 mhz running ICS. It would be interesting if you could port 0.2 as at actually reaches menus and such to a much greater extent. This would be good for judging performance, although I don't think anything other than the most simple pong.elf would ever run decently.

Also, it would be pretty fun to see if I could theoretically play Persona 3 on my phone.


RE: First running on Armv6 device (Wip) - andry - 11-11-2012 12:58 PM

Thank you MaXiMu! It's fully working on my Galaxy Gio (Tested cube.elf and Puzzle Bobble)Big Grin
You will make future versions for ARMv6? Many users will thank you!Smile


New update - MaXiMu - 11-11-2012 09:30 PM

I will update progressively easy to carry while I have little time for it.

I update new version swicth experimentally support Multilib (Armv5+ and armv7)

http://www.multiupload.nl/DI5ZFBWYDR Commit (ce5afbc166)

Note : native/math/math_util.cpp //This build Disable fmrx references no supported by armeabi cpu .


RE: New update - andry - 11-12-2012 03:25 PM

(11-11-2012 09:30 PM)MaXiMu Wrote:  I update new version swicth experimentally support Multilib (Armv5+ and armv7)
This build works good too!Big Grin
Thank you for your work! Keep it up!Rolleyes


RE: First running on Armv6 device (Wip) - Vincentmrl - 11-12-2012 06:00 PM

The last build you made works perfectly on my overclocked (748Mhz) Lg Optimus One with unofficial Cyanogenmod 9, the cube goes at full speed so way faster than the video you made. If you want I can make a video of it or anything like this.


RE: First running on Armv6 device (Wip) - MaXiMu - 11-12-2012 07:00 PM

On my video is very laggy input on youtube but in the real device is works much faster than in the video
If you can create a video with better picture quality and no lag input I'd appreciate it thanks.


RE: First running on Armv6 device (Wip) - matheus abreu - 11-14-2012 03:52 PM

thx work on my Galaxy 5







RE: First running on Armv6 device (Wip) - Vincentmrl - 11-14-2012 09:58 PM

Here's it on my overclocked Optimus One.






RE: New update - Vincentmrl - 11-20-2012 12:27 PM

(11-11-2012 09:30 PM)MaXiMu Wrote:  I will update progressively easy to carry while I have little time for it.

I update new version swicth experimentally support Multilib (Armv5+ and armv7)

http://www.multiupload.nl/DI5ZFBWYDR Commit (ce5afbc166)

Note : native/math/math_util.cpp //This build Disable fmrx references no supported by armeabi cpu .

Version 3.0 have been released, are you working on armv6 port?


RE: First running on Armv6 device (Wip) - MaXiMu - 11-20-2012 07:22 PM

Ok I uploaded new compilation commit 2a56d36b12 with armeabi support

You download here http://www.multiupload.nl/AYMKA5CWYR


RE: First running on Armv6 device (Wip) - Vincentmrl - 11-20-2012 09:53 PM

somehow it goes way slower than 0.2, is it 0.3 or 0.31? Did you make any changes or something? armv7 users said they got a speed boost, so check your build please
Anyway thanks for being so active and helpful with the armv6 ports!