forums.PPSSPP.org
[SOLVED] Problem with AMD - Printable Version

+- forums.PPSSPP.org (https://forums.ppsspp.org)
+-- Forum: PPSSPP - Playstation Portable Simulator Suitable for Playing Portably (/forumdisplay.php?fid=1)
+--- Forum: General Discussion and Announcements (/forumdisplay.php?fid=2)
+--- Thread: [SOLVED] Problem with AMD (/showthread.php?tid=11896)



[SOLVED] Problem with AMD - freakingfreak - 05-26-2014 08:30 PM

Hi there
I have the 0.0.9.8 version of this emulator, and every time I try to play a game after about 3 minutes the emulator suddenly freezes and then a bubble message appears at the tool bar saying that my graphics card has stopped working and recovered or something like this...

What's the problem here? Can I fix it somehow without having to change the graphics card or something?

Obs: I'm playing in a laptop, I tried to play GTA VCS and GTA CW, same thing happens with both roms.

More details:
Toshiba Sattelite C855 2K1
Windows 8 64bits
Intel Core i3 2.30 Ghz
4gb RAM
DirectX 11
AMD Radeon HD 7610M

Can someone help me? This is really frustrating... Huh

(I'm sorry if this isn't the right place for this topic, I just registered so I could get you guy's help on this...)


RE: Problem with AMD - LunaMoo - 05-27-2014 10:23 AM

If you didn't yet, you should just update your drivers to latest version which you can do here. If you by any chance use beta drivers while experiencing crashing, try stable ones. Recently even beta drivers seem ok for me, but I'm on win 7, windows 8 can have it's own problems:|.


RE: Problem with AMD - Nightquaker - 05-28-2014 05:40 AM

(05-26-2014 08:30 PM)freakingfreak Wrote:  Hi there
I have the 0.0.9.8 version of this emulator, and every time I try to play a game after about 3 minutes the emulator suddenly freezes and then a bubble message appears at the tool bar saying that my graphics card has stopped working and recovered or something like this...

What's the problem here? Can I fix it somehow without having to change the graphics card or something?

Obs: I'm playing in a laptop, I tried to play GTA VCS and GTA CW, same thing happens with both roms.

More details:
Toshiba Sattelite C855 2K1
Windows 8 64bits
Intel Core i3 2.30 Ghz
4gb RAM
DirectX 11
AMD Radeon HD 7610M

Can someone help me? This is really frustrating... Huh

(I'm sorry if this isn't the right place for this topic, I just registered so I could get you guy's help on this...)

Oh nice, seems like AMD fucked the OpenGL up again. As Luna said, update your graphics drivers, and as a last resort you can use atioglxx.dll file (AMD's core OpenGL file) downloaded elsewhere to prevent OpenGL crashes of emulator by placing it in the root folder of it. That will make emulator use that file instead of broken default one in a driver and should solve your problem. Keep in mind, though, that only works in 32bit version of PPSSPP.


RE: Problem with AMD - freakingfreak - 05-30-2014 07:38 PM

Thanks for the answers guys, I updated my driver and now everything seems to work just fine... at least the graphics card doesn't crashes anymore since I updated the driver, and the emulator runs smoothly too.

... and by the way, this is surely the best/fastest PSP emulator I've ever tried, congratulations for the developers! Big Grin