forums.PPSSPP.org
How to eliminate choppy sound - Printable Version

+- forums.PPSSPP.org (https://forums.ppsspp.org)
+-- Forum: PPSSPP - Playstation Portable Simulator Suitable for Playing Portably (/forumdisplay.php?fid=1)
+--- Forum: Development (/forumdisplay.php?fid=3)
+--- Thread: How to eliminate choppy sound (/showthread.php?tid=11245)

Pages: 1 2


How to eliminate choppy sound - belmont1990 - 03-25-2014 11:10 AM

I'm testing ppsspp for some time now, it runs really great and compatibility is high, definitely in my top 3 emu of all time (along with ePSXe and PCSX 2) Smile

However I have one small problem, some games gives my choppy sound effects while fps drops quite much, i had this mostly in 3rd birthday which runs on 30 fps by default.
On some intense scenes like explosions and flashing fps drops to about 15-20 (enabled frameskip to 1, auto) that's okay to me but why sound gets choppy then? Is there any option to make it play normally or slower but WITHOUT being choppy and cracky?
I am heavy epsxe user and there is option like this in some sound plugins.

Also another thing, on games like megaman x maverick hunter while the fps drops from default 60 to 30-40 on boss presentation, sound plays just fine, only gameplay skips frames, I would like to do this on higher drops too.


RE: How to eliminate choppy sound - Accel - 03-25-2014 03:26 PM

im not a pc/game specialist but when FPS(Frames Per Second) drop below 30, the sound tries to sync with the frames thats why its choppy

did i get that right? correct me if im wrong Big Grin


RE: How to eliminate choppy sound - vnctdj - 03-25-2014 05:37 PM

Is your problem similar to this one ?


RE: How to eliminate choppy sound - belmont1990 - 03-25-2014 06:48 PM

Hmm I don't find it similiar because in my case sound is cracking and chopping only in some intense scenes like special attacks in FF Crisis Core, body transitions in 3rd birthday/ some big explosions and flashing.
The problem is sound gets choppy while fps drops below some point, like below 30 fps in native 60 fps games, and below 15-20 for native 30 fps.

For example epsxe emulator have sound option called "async - smooth", which seems to just slow down music and effects instead of making them choppy, and this really boosts those heavy parts on higher settings making them more comfortable to hear.
I'm looking for same solution on ppsspp.


RE: How to eliminate choppy sound - Accel - 03-25-2014 09:25 PM

(03-25-2014 06:48 PM)belmont1990 Wrote:  For example epsxe emulator have sound option called "async - smooth", which seems to just slow down music and effects instead of making them choppy, and this really boosts those heavy parts on higher settings making them more comfortable to hear.
I'm looking for same solution on ppsspp.

hmm i would also love to see that option in ppsspp Tongue

like i explain before, this situation is common(i always encounter the problem in almost all games) and unfixable(unless some magic brains solved it)


RE: How to eliminate choppy sound - belmont1990 - 03-26-2014 09:23 AM

Okay, we just have to live with it (for now) or set rendering to 1x which makes even most system-heavy parts go full speed Wink
It would be soooo DAMN HOT to see async in ppsspp future builds *.*


RE: How to eliminate choppy sound - Accel - 03-27-2014 12:00 PM

try make a request to speed up the wishes XD


RE: How to eliminate choppy sound - Merivex - 03-31-2014 11:44 AM

(03-25-2014 11:10 AM)belmont1990 Wrote:  I'm testing ppsspp for some time now, it runs really great and compatibility is high, definitely in my top 3 emu of all time (along with ePSXe and PCSX 2) Smile

However I have one small problem, some games gives my choppy sound effects while fps drops quite much, i had this mostly in 3rd birthday which runs on 30 fps by default.
On some intense scenes like explosions and flashing fps drops to about 15-20 (enabled frameskip to 1, auto) that's okay to me but why sound gets choppy then? Is there any option to make it play normally or slower but WITHOUT being choppy and cracky?
I am heavy epsxe user and there is option like this in some sound plugins.

Also another thing, on games like megaman x maverick hunter while the fps drops from default 60 to 30-40 on boss presentation, sound plays just fine, only gameplay skips frames, I would like to do this on higher drops too.

For now ,, I recommend you to switch your cpu governor to Performance so you'll not get the choppy sound .. Like mine ,, the setting that I use is Buffered rendering 3x and no frameskip Smile No lag at all after changing the governor Wink and don't forget to turn off the atomic audio locks .. It'll make choppy sound ..


RE: How to eliminate choppy sound - Henrik - 04-02-2014 02:21 PM

I've tried a couple of simple ideas for audio smoothing but haven't gotten good results. I plan to have another go at this at some point though.


RE: How to eliminate choppy sound - Zero3K - 04-06-2014 06:30 PM

I also notice pops/crackling noises in the audio of the games I play and is more evident in Mana Khemia: Student Alliance.


RE: How to eliminate choppy sound - makotech222 - 04-07-2014 01:14 AM

Yeah a time-stretching code would fix this. I've never touched anything sound related, though. Pcsx2 has code for it, if you're looking for ideas on how to implement it.


RE: How to eliminate choppy sound - Zero3K - 04-13-2014 02:47 AM

(04-07-2014 01:14 AM)makotech222 Wrote:  Yeah a time-stretching code would fix this. I've never touched anything sound related, though. Pcsx2 has code for it, if you're looking for ideas on how to implement it.

Is it going to be implemented or not?


RE: How to eliminate choppy sound - Zero3K - 05-01-2014 01:15 AM

Any luck with fixing it?


RE: How to eliminate choppy sound - The Phoenix - 05-01-2014 01:30 AM

(05-01-2014 01:15 AM)Zero3K Wrote:  Any luck with fixing it?
Henrik is busy coding other parts of the core of the emulation, but will get around to this problem i am sure in due time.

So patients my friend. Tongue


RE: How to eliminate choppy sound - ps8ps8 - 05-01-2014 12:31 PM

Just testing this Amazing emulator on my Acer 18.4" 8930g, 9700m gt, Core2 E8335 2.93GHz, Vista Home Prem.
LittleBigPlanet at 1080p looks almost PS3 like except the 2d popup text/gfx stay lowres.
-turning Texture Scaling OFF eliminate almost all sound popping/cracking only some during loading/access next scene/memory, so soundproblems comes down to heavy GPU processing/overload.